Версия для печати

Нажмите сюда для просмотра этой темы в обычном формате

Nucleus CMS RuSupport _ Проблемы с установкой _ Проблема с чем то непонятным

Автор: ViTaLiK Nov 9 2006, 04:46 PM

Вот скачал последнюю версию этого движка и уже 2 дня голову ломаю что же делать, проблема в следующем:
значит на главной странице надпись - "Ошибка скина", бэкапы пробовал не получается, далее в свойствах ставил галку "только читать" в config.php, а не работает я думаю из-за того что когда хочу залить скин на сервак то появляется следующее: (всё происходит на Денвере)
Warning: fwrite(): supplied argument is not a valid stream resource in z:\home\opa.ru\www\nucleus\libs\skinie.php on line 144

Warning: rewind(): supplied argument is not a valid stream resource in z:\home\opa.ru\www\nucleus\libs\skinie.php on line 145

Warning: fread(): supplied argument is not a valid stream resource in z:\home\opa.ru\www\nucleus\libs\skinie.php on line 147

Warning: fclose(): supplied argument is not a valid stream resource in z:\home\opa.ru\www\nucleus\libs\skinie.php on line 155

где opa.ru - пример сайта .... что делать помогите, я не в курсе уже ... что исправить надо, я уже прям без надежд ...

Автор: saj Nov 9 2006, 07:49 PM

Можно ли зайти в админку? Что пишет при установке скинов default и grey?

Я так понял что файлы install удалены, а на config.php поставлен аттрибут read-only.

Стоит внимательно проверить пути, которые вводились при инсталляции.

Как нужно ставить на денвере(кажется, ссылки еще живы):
http://www.filefactory.com/file/6e2173/
http://www.uploading.com/files/3HQEAZDK/denver_install.zip.html

Распаковать и запустить html-файл. Записано с разрешением 1024х768, поэтому рекомендуется смотреть при более высоком разрешении или развернув броузер (например, Opera) во весь экран (F11).


Автор: Suvoroff Nov 9 2006, 07:53 PM

Что то участились проблемы со скинами при установке на денвре (http://www.nucleus.com.ru/forum/index.php?act=Search&CODE=show&searchid=95e312073cc4ce636c64e1b3d47fad02&search_in=posts&result_type=topics&highlite=%CE%F8%E8%E1%EA%E0+%F1%EA%E8%ED%E0)
попробуйте использовть не самый последний архив денвера, я уже года 2 своим пользуюсь ни разу не переустанавливал и все работает..

Автор: ViTaLiK Nov 10 2006, 02:25 AM

В вобшем в админку заходить могу, а вот как только иду на сайт, ошибка скина, Денвер вроде у меня не старый, вот в вобщем не знаю что и делать, мне кажется тут не всё в поряде с файлом
z:\home\opa.ru\www\nucleus\libs\skinie.php, я так думаю, сможете залить сюда этот файл, мож действительно из-за этого, так как я скачивал эту платформу с англ сайта ...

Автор: scar Nov 10 2006, 06:15 AM

Цитата(ViTaLiK @ Nov 10 2006, 09:25 AM) *

В вобшем в админку заходить могу


Проверь скины и шаблоны. У меня была такая ошибка, но не на локальном хосте а на вебхосте. Победил ее так [attachmentid=49]. Если у тебя все впордке в скинах и шаблонах тогды не знаю... возможно у тебя что то другое.

 

Автор: ViTaLiK Nov 10 2006, 09:56 AM

ты предлагаешь, это всё написать? у меня короч в админке не столько надписей как у тебя у меня тока "Главная страница" - объясни мои следующие действия ... очень нужно ...

Автор: scar Nov 10 2006, 10:34 AM

посмотри тут --> http://www.nucleus.com.ru/forum/index.php?showtopic=116
у меня проблема была немного другого плана. на localhost все работало а в вебе нехотело.
Я установил локально на Денвере-2 все ОК! установил на вебхосте ошибка скина.
Открыл локално админу и копированием добавил чего не достовало в интернете... но после этого начались другие проблемы не добовлялись категории и т.д. Это кратко!!!
ИМХО лучше нормально настрой локально а потом в интернете. Это моё мнение.

чего тебе посоветовать:
1. Денвер попробуй поставить заново, я месяц назад скачивал нормально работает.
2. На вебхосте установи посмотри будет ли такая же ошибка.


ps. Пробуй всяко разно. Если долго мучатся что-нибудь получится smile.gif

Автор: saj Nov 10 2006, 02:24 PM

У scar совсем другая проблема.

Ситуация на денвере описана на этом форуме (см. ссылку в посте Suvoroff'a). Также см.
http://nucleus.net.ru/forum/viewtopic.php?id=20

Видно, что ошибку выдает один и тот же файл и одни и те же строки, а именно:

Код

        $temp = tmpfile();
        [b]fwrite($temp, $tempbuffer);[/b]
        [b]rewind($temp);[/b]

        [b]while ( ($buffer = fread($temp, 4096) ) && (!$metaOnly || ($metaOnly && !$this->metaDataRead))) {[/b]
            $err = xml_parse( $this->parser, $buffer, feof($temp) );
            if (!$err && $this->debug)
                echo 'ERROR: ', xml_error_string(xml_get_error_code($this->parser)), '<br />';
        }

        // all done
        $this->inXml = 0;
        [b]fclose($temp);[/b]


Я сколько не пробовал ошибок воспроизвести так и не смог smile.gif Можно предположить что что-то не так с путями(покажите скрин с путями, которые указываются при установке). Чтобы избежать этого, повторите все как показано на записи - с точностью до знака smile.gif smile.gif
Впрочем возможно, дело и в настройках денвера.

Автор: Suvoroff Nov 10 2006, 06:54 PM

Что то у меня закрались подозрения, что ошибка возникает при использовании руского ленга от небезызвестноо саахова, который перевел названия частей шаблонов скинов.
У кого была ошибка, скажите использовали ли вы русский язык, если да то где его взяли.

Автор: ViTaLiK Nov 11 2006, 03:21 AM

Да у меня русиш стоит, а скачал его вместе с cms, по моему на оф.сайте, да вроде там, там есть типа что то скачать языки, там их куча целая ... suvoroff или saj не могли бы вы мне кинуть файл skinie.php - желательно в открытом виде, а не в zip или rar'e. За ранее благодарен, буду дальше мучать ... да и кстати не один из скинов так и не встаёт правильно, я скачал: gnoo, greeneye и так далее, они тоже не хотят вставать, надеюсь на помощь ...
scar а почему у тебя на картинке есть Главная страница, архив, список архива и так далее а у меня такого нету у меня тока главная страница ...

Автор: saj Nov 11 2006, 09:30 AM

Цитата(ViTaLiK @ Nov 11 2006, 04:21 AM) *

Да у меня русиш стоит, а скачал его вместе с cms, по моему на оф.сайте, да вроде там, там есть типа что то скачать языки, там их куча целая ...

Какова точная последовательность установки: инсталляционный скрипт запускается с языковым файлом в папке nucleus/language или же Nucleus устанавливается без языкового файла, а значит ошибка возникает не . Попробуйте устанавливать Nucleus без языкового файла - в том виде в котором он поставляется на оффсайте. Будет ли ошибка? А если потом установить ленг-файл(раз уж на то пошло, то желательно от Suvoroff'a)


Цитата(ViTaLiK @ Nov 11 2006, 04:21 AM) *

suvoroff или saj не могли бы вы мне кинуть файл skinie.php - желательно в открытом виде, а не в zip или rar'e.


Проблема не файле, такие же самые ошибки, с теми указанием на теже самые строки уже появлялись у других пользователей.
А файл вот. В самом открытом виде/* в аттач у меня не влезло, поэтому надо будет удалить, чтобы топик не засорять */:


Цитата(ViTaLiK @ Nov 11 2006, 04:21 AM) *

да и кстати не один из скинов так и не встаёт правильно, я скачал: gnoo, greeneye и так далее, они тоже не хотят вставать, надеюсь на помощь ...

Чего пишет?

Цитата(ViTaLiK @ Nov 11 2006, 04:21 AM) *

scar а почему у тебя на картинке есть Главная страница, архив, список архива и так далее а у меня такого нету у меня тока главная страница ...

Это потому что скины не установились.

Автор: ViTaLiK Nov 11 2006, 09:14 PM

делаю следующее: устанавливаю cms далее кладу ru файлы в директорий (скаченные с оф.сайта) далее в настройках в админке то есть выбираю русский, и всё не работает ....
на счёт скинов gnoo и так далее ничего сказать не могу та же ошибка ...
код можешь стирать я его коирнул ...

Автор: ViTaLiK Nov 11 2006, 09:35 PM

короч скачал 3.24, русиш с этого сайта, скин умора ... начну мучать ... в общем если ничё не получится и не знаю что делать ...

Автор: Suvoroff Nov 11 2006, 10:58 PM

Цитата
далее кладу ru файлы


Ленг с этого сайта скачан?
Если нет попробуй всю последовательность точно также, только ленг отсюда: http://www.nucleus.com.ru/forum/index.php?automodule=downloads&showfile=17

Автор: ViTaLiK Nov 12 2006, 07:44 PM

Suvoroff, ок я поробую, у меня как я сказал всё новое, буду пытать

Автор: scar Nov 13 2006, 02:09 AM

Цитата(ViTaLiK @ Nov 11 2006, 10:21 AM) *

scar а почему у тебя на картинке есть Главная страница, архив, список архива и так далее а у меня такого нету у меня тока главная страница ...

А это потому что я уже тут ручками поработал... huh.gif

Цитата(Suvoroff @ Nov 11 2006, 01:54 AM) *

Что то у меня закрались подозрения, что ошибка возникает при использовании руского ленга от небезызвестноо саахова, который перевел названия частей шаблонов скинов.
У кого была ошибка, скажите использовали ли вы русский язык, если да то где его взяли.


движок и перевод взяты у товарища саахова....

Цитата
<?php
// Russian Nucleus Language File
//
// Author: Andrey Serebryakov - saahov[@]gmail.com
// Nucleus version: v1.0-v3.2
// Update: 19.10.2005
// Вопросы по управлению, настройке и модернизации Nucleus можно
// задать на форуме сообщества русских пользователей: [http://nucleus.net.ru].


только я непойму почему локално все ОК! cool.gif, а в инете ЖОПА!!! mad.gif

Автор: scar Nov 13 2006, 03:37 AM

хых попробовал поставить v.3.24 опять 25!!! mad.gif

Автор: Suvoroff Nov 13 2006, 01:53 PM

Читай выше.
Попробуй перевод не от товарища саахова

Автор: saj Nov 13 2006, 05:47 PM

Цитата(ViTaLiK @ Nov 11 2006, 09:14 PM) *

делаю следующее: устанавливаю cms далее кладу ru файлы в директорий (скаченные с оф.сайта) далее в настройках в админке то есть выбираю русский, и всё не работает ....
на счёт скинов gnoo и так далее ничего сказать не могу та же ошибка ...
код можешь стирать я его коирнул ...


Милый человек, я хоть убей не могу понять следующее:

1. Повторяется ли упомянутая ошибка, если устанавливать движок без лэнг-файла - т.е. непосредственно в том в виде, как он скачан с официального сайта, на английском языке.
2. Что происходит, если в админке войти в пункт экспорт/импорт и и в разделе импорт выбрать grey. Пишется ли чего нибудь?

Автор: scar Nov 14 2006, 06:59 AM

Цитата(Suvoroff @ Nov 13 2006, 08:53 PM) *

Читай выше.
Попробуй перевод не от товарища саахова


Я всяко пробовал и с ленгом (от саахова и от суворова) и без ленга.
нуклеас с оффсайта, ленг-и тоже...
че еще руки мои, может в этом дело... smile.gif

p.s. хотя у меня все работает... делаю все локально сперва, создаю бэкап. затем устанавливаю в интернете с "ошибка синка" и через админку делаю воостановление... после чего все работает blink.gif на удивление. вот такие вот пироги!!!

suvoroff, saj может всетаки добъем эту ошибку "skin error" - "ошибка скина".
можно на моем примере smile.gif , могу дать доступ к своему сайту...
если конечно это вам интересно!?
надо бы покончить с этим раз и навсегда...

Автор: ViTaLiK Nov 14 2006, 08:18 PM

scar а ты что именно ручками правил ...

Автор: scar Nov 15 2006, 02:07 AM

А у вас какие успехи мучали мучали и чего намутили?

Цитата(ViTaLiK @ Nov 15 2006, 03:18 AM) *

scar а ты что именно ручками правил ...


В админке --> Внешний вид --> Скины
На странице редактирование скинов
Дописал Описания: Архив, Главная, Поиск и т.д.

В админке --> Внешний вид --> Шаблоны
На странице редактирование шаблонов
Тут тоже подправил default шаблоны.

Вобсчем доделал, что не установилось...

ps. но этот способ не есть хорошо, не все после этого работает, капай в сторону Денвера как тебе советовали... =)

Автор: scar Nov 16 2006, 09:31 AM

где можно редактировать ссылки между статичными страницами(1, 2) и страницой блога, чтобы их связать. создал разделы 1,2, блог, а связать их ссылками не получилось. нашел где это можно сделать sad.gif
помогите пожаалйста кто знает.

Автор: Suvoroff Nov 16 2006, 02:17 PM

Это к теме топика не относится, сойдай новую тему.

Автор: Ruzzz Nov 20 2006, 04:39 AM

Блин, то же самое! Поставил на Jino. Локально все работало, в вебе нет - Skin error! права на config выставил 444, install (оба) удалил! В админ панель захожу - не установились скины и шаблоны, ПРИЧЕМ Я НЕ МОГУ ИХ УСТАНОВИТЬ! На этом хостинге показ ошибок отключен( можна включить) но мне кажется что у меня аналогичная ситуация! Да чтож делать то а?

Автор: Suvoroff Nov 20 2006, 06:05 PM

Это http://jino-net.ru/?
Сегодня специально акк зарегаю чтобы все проверить

Автор: Ruzzz Nov 21 2006, 09:56 AM

Да! Посмотри пжлста!

Автор: Suvoroff Nov 21 2006, 11:13 PM

ну в общем все понятно
на хостинге стоит запрет на xml файлы - а именно из них делается восстановление скинов и шаблонов
думаю на других хостингах аналогичная проблема (где выдается ошибка скина)
там кстати у них на хостеровском форуме куча проблем обсуждается с невозможностью поставить тот или иной движок, и 90% из-за того что xml не читается

Автор: Ruzzz Nov 27 2006, 02:24 AM

Огромное спасибо!

Русская версия Invision Power Board (http://www.invisionboard.com)
© Invision Power Services (http://www.invisionpower.com)