IPB

Здравствуйте, Гость ( Вход | Регистрация )

 
Ответить в этой темеОткрыть новую тему
> JavaScript в тексте поста?
articles
сообщение Nov 18 2007, 04:50 PM
Сообщение #1


Advanced Member
***

Группа: User
Сообщений: 44
Регистрация:
27-April 06
Пользователь №: 118



Пытаюсь вставить JavaScript в статю, но движок вырезает.
Пробовал без WiSing и c Wising редактором, ничего не выходит.
Как быть и что поменять?


--------------------
К началу страницы
 
+Цитировать Сообщение
Suvoroff
сообщение Nov 19 2007, 02:04 AM
Сообщение #2


Support Staff
***

Группа: Admin
Сообщений: 1,170
Регистрация:
16-July 05
Из: nucleus.com.ru
Пользователь №: 1



хм. вырезать не должен.
что может быть - вставка < br > автоматически (из-за чего весь код портится). Нужно сначала отключить автоматический перенос строк, добавить пост и затем снова включить
или у Вас совсем вырезает весь текст


--------------------
К началу страницы
 
+Цитировать Сообщение
articles
сообщение Nov 19 2007, 09:58 AM
Сообщение #3


Advanced Member
***

Группа: User
Сообщений: 44
Регистрация:
27-April 06
Пользователь №: 118



ЦИТАТА(Suvoroff @ Nov 19 2007, 03:04 AM) [snapback]2491[/snapback]
хм. вырезать не должен.
что может быть - вставка < br > автоматически (из-за чего весь код портится). Нужно сначала отключить автоматический перенос строк, добавить пост и затем снова включить
или у Вас совсем вырезает весь текст

Беру с youtube код ролика. Вставляю в визуальном редакторе через "html":
<object width="425" height="355"><param name="movie" value="http://www.youtube.com/v/vfLNGTkAXEo&rel=1&border=0"></param><param name="wmode" value="transparent"></param><embed src="http://www.youtube.com/v/vfLNGTkAXEo&rel=1&border=0" type="application/x-shockwave-flash" wmode="transparent" width="425" height="355"></embed></object>

и остается:
<object width="425" height="355"><param name="movie" value="http://www.youtube.com/v/vfLNGTkAXEo&amp;rel=1&amp;border=0"></param><param name="wmode" value="transparent"></param></object>
Причем, если в настройках TinyMCE2 ставлю отключить, ничего не происходит! Он не отключается...
Интересно, а что такое Extended valid elements that are allowed in TinyMCE object[*],param[*],embed[*] в параметрах TinyMCE2? Может в этом дело?


--------------------
К началу страницы
 
+Цитировать Сообщение
articles
сообщение Nov 19 2007, 10:22 AM
Сообщение #4


Advanced Member
***

Группа: User
Сообщений: 44
Регистрация:
27-April 06
Пользователь №: 118



embed[*] - вырезает...?
TinyMCE2 1.2


--------------------
К началу страницы
 
+Цитировать Сообщение
articles
сообщение Nov 19 2007, 10:54 AM
Сообщение #5


Advanced Member
***

Группа: User
Сообщений: 44
Регистрация:
27-April 06
Пользователь №: 118



Обновил до 1.3 и все OK! В 1.2 tinymce2 - ошибка


--------------------
К началу страницы
 
+Цитировать Сообщение

Ответить в этой темеОткрыть новую тему
1 чел. читают эту тему (гостей: 1, скрытых пользователей: 0)
Пользователей: 0

 



Текстовая версия Сейчас: 23rd November 2019 - 02:24 AM
Рецепты - Скачать программы - Scripts