Версия для печати

Нажмите сюда для просмотра этой темы в обычном формате

Nucleus CMS RuSupport _ Проблемы с установкой _ Кодировка

Автор: Corvus May 19 2007, 02:20 PM

Всем привет. Порылся по форума ответа ненашёл.



траблы с кодировкой. пробыал вынуть базу и загрузить заного под cp1251 , не помогло.
Что можно дслеать?

Спасибо, извиняюсь если вопрос уже задавали и я пропустил.

да при установке русского языка весь сайт превращается в колекцию ироглифов... )

Автор: Suvoroff May 19 2007, 10:34 PM

ЦИТАТА
да при установке русского языка весь сайт превращается в колекцию ироглифов... )


хм. должен нормально оторбражаться. может это ваши личные настройки браузера?
В движке фундаментально кодировка передается через хеадеры, в свою очередь кодировка задается через ленг файл. Проверьте еще раз, правильно ли увас установлена кодировка в языковом файле (ищите charset), если не поможет попробуйте задать кодировку через <meta> или .htaccess

Автор: Corvus May 20 2007, 04:19 PM

ЦИТАТА
хм. должен нормально оторбражаться. может это ваши личные настройки браузера?


Пробывал с несколькими браузера и компами sad.gif

ЦИТАТА
попробуйте задать кодировку через <meta>


Изначальна пробывал прописать
<meta http-equiv="content-type" content="text/html; charset=windows-1251" />
нема.

ЦИТАТА
правильно ли увас установлена кодировка в языковом файле (ищите charset


Так дык, даже когда я просто новость постю только ироглифы лезут.

Автор: Suvoroff May 21 2007, 06:28 PM

Ссылку в студию

Автор: brutaltag Sep 23 2013, 02:58 PM

У меня не сохраняются настройки, написанные кириллицей (плагины, даже название блога). В чем может быть дело?

Автор: Suvoroff Sep 23 2013, 06:03 PM

Что именно происходит? Ошибка есть какая-нибудь? Никогда с таким не сталкивался

Автор: brutaltag Sep 25 2013, 01:52 AM

Такой случай. Переводил блог на другой хостинг с одновременным апгрейдом с 3.33 до 3.65 - зря, половина плагинов напрочь обрубились. Проблема эта с русскими символами. В БД они сохраняются, если смотреть через Adminer, но в браузере не всегда выводятся. Например, правлю имя блога, пишу "ФУПМ ВИКЛИ" на русском - сайт отображается в браузере с заголовком - URL www.fupmweekly.ru (сейчас указывает пока на старый хостинг), пишу FUPM WEEKLY - в заголовке именно это и есть. Возможно, проблема связана с украинским сервером и некоторыми настройками collate? Но для версии 3.65 на заграничном форуме я нашел патч и проблема исчезла. Сейчас решил переносить блог без апгрейда, плагины все ок, кроме капчи, а невывод заголовка остался

Автор: Suvoroff Sep 30 2013, 12:18 PM

Плагины не должны были обрубиться, у меня на 3.65 все работает из перечисленного
С кодировкой тоже не все понятно, возможно в языковом файле нужно указать cp-1251

Автор: brutaltag Sep 30 2013, 12:57 PM

Посмотрел, что предлагалось в патче 3.65.1 - в htmlspecialchars явно указывается чарсет, есть такая фишка у новой версии PHP что он по умолчанию предлагает кодировку UTF8. Везде или почти везде указал в своей версии 3.33 такие же правки, в итоге после дня мучений и основательного редактирования ядра и замены плагина NP_Captcha на NP_CaptchaLite почти все заработало

Автор: Черный Ангел Oct 16 2013, 07:13 AM

С кодировкой на локальном сервере были проблемы.
Установил на хостинг джин, ни каких проблем небыло ни какие файлы не менял

Русская версия Invision Power Board (http://www.invisionboard.com)
© Invision Power Services (http://www.invisionpower.com)